Proxy Generation: error occured


#1

Buen dia @Alvan1, me dio un error al momento de finalizar la creación del proxy.

Te muestro la imagen, ver si me puede orientar, estoy siguiente tu manual, por cierto excelente.

Mas no se si es por algo que se me haya pasado, según yo no. O bien falte alguna configuración del BASIS.

De antemano muchas gracias.


Web Services - Parte III (Creac. de Consum. Proxy)
#2

Pues yo me inclinaría a que el WSDL no esta generado correctamente, los estas creando a través de un archivo o una URL el proxy.

Ya has creado antes Servicios WEB ahí donde estas actualmente trabajando?, tienes acceso al SOAMANAGER? te pregunto por que cuando empece aqui tuvieron que actualizar unos hot package para que pudiera desarrollar correctamente.

Y si todo lo anterior es SI entonces hay que checar el WSDL.

Saludos,.


#3

Si ya tengo acceso a SOAMANAGER es parte con la que estoy trabajando con los BASIS.

lo estoy creando a travez de una URL.

Mas estoy viendo por lo mensajes que ponen por ejemplo. Quiero realizar un TEST y me marcar error de J2EE que no esta configurado el puerto.


#4

prueba con esta config.

Despues de que crees tu servicio.

Por que a mi igual me salia igual pero con la config que te muestro debiera de quedar


#5

La imagen que envias asi lo tengo la diferencia es lo que muestras al lado derecho superior, supongo por la versión que se utiliza

Por cierto no respondi totalmente a tu pregunta de la anterior.

NO SE CREADO SERVICIO WEB. Estoy haciendo pruebas en nuestro servidor de desarrollo y pidiendo a los BASIS la configuraciones. Saludos.


#6

nuestro SAP esta asi:

Tambien verificar que todos los servicios del SICF correspondientes a la WS esten activos.


#7

Ok en estos momento BASIS esta ya verificando muchas gracias por tu ayuda y te comento.


#8

Que tal.

Fijate que dentro del SOAMANAGER trae un analizador. Y efectivamente el mismo error que me da cuando quiero crear el proxy, me dio al momento de analizarlo. Tienes alguna idea, el porque me esta dando ese error.


#9

Ya checaste la transaccion SICF, en la ruta de sap/bc/srt/wsdl, de que el servicio este activo.

Por que la verdad no se me hace nada conocido ese error, yo mi inclino a que hace falta la activavion de algunos servicios de la SICF.

Suerte estimado.


#10

Ok muchas gracias y disculpa las molestias, pero si le ando moviendo en un lugar y otro y con el basis.


#11

Eloy eso lo solucionas aplicando una nota de SAP (2388992) a mi tambien me paso y logre solucionarlo.