Ayuda SAP

Incompatibilidad Windows 10 y SAP B1 9.0

Buen dia, antes de acudir a este grupo de consulta investigue por mi cuenta pero la respuesta parecida a mi problema data del 2016, detallo mi consulta tengo el SAPB1 9.0 y este año cambie mi laptop viniendo instalada con Windows 10 alguna de las actualizaciones del Widows 10 no deja que el programa funcione.
En respuesta mencionada en el 2016 para solucionar el problema se menciona una actualización KB31xxxxx , sin embargo esta no se encuentra dentro del historial de actualizaciones .

Agradezco de antemano por el apoyo

No hay forma de que vayas a una versión superior de tu B1 ? Ej. 9.1 ?


Edito, info oficial afirma que para que haya soporte de Win 10, debes tener al menos SAP B1 9.1 PL10 o bien, SAP Business One 9.2 PL00.

Fuente: h_tps://archive.sap.com/discussions/thread/3753030

2 Me gusta

Estimado @Miguel1
Como bien dice @SidV SAP te recomienda, que lo mejor es que migres a SAP B1 9.1 o superior, es la solucion por excelencia.
Yo tuve el mismo problema con la version 9.0 PL15, pero por lo complejo que muchas veces se hace migrar a una version superior, y las diversas variables que se involucran, busque y encontré aqui en este mismo foro la solucion.

La puedes ver en la discusion siguiente: (alli te indican que la solucion es aplicar lo que dice la nota de SAP no. 2334025… hasta el final de la discusion, mencionan eso)

Te coloco la parte de la nota de SAP que yo aplique en el servidor productivo y que si me funcionó:

1. Back up the server.xml file (C:\Program Files (x86)\SAP\SAP Business One ServerTools\System Landscape Directory\tomcat\conf).
On Linux the server.xml file can be found in the following location: /usr/sap/SAPBusinessOne/Common/tomcat/conf

2. Open server.xml in \conf
3. Find element in this xml.
4. Change attribute sslEnabledProtocols value to “TLSv1,TLSv1.1,TLSv1.2”
5. Add a new attribute:

ciphers=”TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256,TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA,TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384,TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA,TLS_ECDHE_RSA_WITH_RC4_128_SHA,TLS_RSA_WITH_AES_128_CBC_SHA256,TLS_RSA_WITH_AES_128_CBC_SHA,TLS_RSA_WITH_AES_256_CBC_SHA256,TLS_RSA_WITH_AES_256_CBC_SHA,SSL_RSA_WITH_RC4_128_SHA”

6. After update the xml file, please restart SLD service.
7. Then logon to SAP Business One or try the installation of SAP Business One Server again.

For more information and discussions please see the SAP Business One Application space on SCN, h_tp://scn.sap.com/community/business-one/content.

Te recomiendo que antes de hacer cualquier cambio en tu servidor productivo, de preferencia lo puedas hacer en un servidor de pruebas, si eso no te es posible, de todas formas antes de aplicar algun cambio, hagas backup de carpetas y archivos que vas a modificar.

Recuerda que en ultimo caso sos el responsable del sistema en tu empresa.

Espero te sirva esto.
Saludos.

2 Me gusta

Te agradezco mucho por el soporte y sobre todo por darme una alternativa adicional

1 me gusta

Estimado Miguel.

Los Clientes SAP de la versión 9.0 presentan inconveniente ya que no cuentan con el soporte para Win10, así mismo te adjunto una imagen del documento enviado por sap para los requerimientos en cada versión.

Requerimientos

Saludos.

2 Me gusta

Este tema se cerró por inactividad por parte del autor.

Copia la URL de este debate, y abre un nuevo tema en #feedback si:

  • El autor del debate no marcó ninguna respuesta como solución, y tú crees tener la solución
  • Crees tener otra solución a la que actualmente está marcada.

Si, en cambio tienes una duda parecida a la que se debatió, o la misma duda, abre un nuevo tema en la categoría que corresponda y pon que el tema se debatió oportunamente (pega el enlace a este debate), así los otros lectores pueden saber de qué hablas.

Ayúdanos a tener una comunidad organizada.