Ayuda SAP

Linked button a UDO

Etiquetas: #<Tag:0x00007f01b92ceb08>

Muy buen día estimd@s,

Acudo a sus conocimientos para salir de un tema que no he podido solucionar.

Tengo un Linked button apuntando a un UDO,

image.png

en el código lo tengo asignado de esta manera:

image.png

Pero no está funcionando el link, ya probe con un objeto estandar y su funcionamiento es optimo, que me puede estar faltando anexar o en donde puede estar mi error?

Muchas gracias por su tiempo y comentarios.

@eduardo_buitr, fijate por favor cómo salen las capturas (no son visibles).

Si tienes código, debes pasarlo como texto para que puedan analizarlo los lectores.

Por favor lee: Cómo usar el foro de Consultoria-SAP
El tema de las capturas está explicado ahí, y cómo pegar código correctamente.

Saludos

Muchas gracias por tu consejo,

De esta manera tengo el codigo del button:


Me.LinkedButton0.LinkedObject = SAPbouiCOM.BoUDOObjectType.udo_MasterData
Me.LinkedButton0.Item.LinkTo = "Edcndc"
Me.LinkedButton0.LinkedObjectType = "IDdeUdo"

Pero no me abre la ventana del Udo cuando doy clic sobre el.

Hola @eduardo_buitr
Para que un Linked button funcione sobre un UDO, se debe tener un formulario por defecto.
De lo contrario te queda el camino mas comun y es:

  1. Abrir formulario del UDO en modo busqueda.
  2. Asignar el DocEntry
  3. Activar el boton de buscar.

Lo anterior mediante la UI-API

Andres Ramirez Jaramillo :colombia:

Te refieres a esto?
Me.LinkedButton0.LinkedObjectType = “IDdeUdo”