Ayuda SAP

Reporte ALV no me trae datos

Trato de organizarlos y resulta igual.

corregí esta así…

Al realizar tus querys el resultado tiene que ser guardado en una tabla que tenga los mismos tipos de datos que el resultado del query.
ejemplo:
Creo la estructura referenciando a los campos q obtendre en mi resultado.
data: begin of t_tabla occurs 0,
carrid like sflight-carrid,
connid like sflight-connid,
fldate like sflight-fldate,
end of t_tabla.

al hacer el query, tengo que guardar el resultado en una tabla.

select carrid connid fldate
into table t_tabla
from sflight.

Despues del “INTO” en tu query tiene que ir el nombre de la tabla interna que antes has debido de crear.
Para tu ultimo query:

DATA: BEGIN OF T_KONA OCCURS 0,
KAPPL LIKE T6B2-KAPPL,
END OF T_KONA.

SELECT KAPPL
INTO T_KONA
FROM T6B2
WHERE KOBOG EQ KONA-KOBOG.

1 me gusta

Ahora que los tienes organizados, te recomendaría ir select por select debugueando.

O sea, debuguea el primer select, y verifica que te traiga datos, y que los datos que te traiga estés correctamente guardados en el campo que corresponde. Una vez verificado eso, pasas al siguiente select y asi hasta completar la tabla interna LT_INTERNA, que es la que se va a mostrar en el ALV.

Saludos.

3 Me gusta

Gracias a todos los que estuvieron pendientes del foro y si seguí el consejo de todos y así pude resolver mi reporte en estos momentos sigo en el pero ya puedo seguir sola ya que son cosas muy básicas para mi y las puedo hacer gracias
espero seguir aprendiendo.

3 Me gusta