Problemas con WebService - Basis


#1

Buenos días Amig@s, solicito de su apoyo con este tema. se creó un WebService en SAP, y generó la siguiente URL

http://ecc-sap-qas:8010/sap/bc/srt/wsdl/bndg_E725FFF8EE8674F19FC300155D013404/wsdl11/allinone/ws_policy/document?sap-client=200, donde cambio ecc-ssap-qas por la IP Pública, esta IP es la que utilizo en mi SapRouter, sin embargo, me envía el error de que no se puede mostrar la página


pero si a la URL le coloco la IP del servidor, esta funciona sin ningún problema, claro, estando dentro del domini, ya que la IP del servidor no es pública.

Será que los Amigos de @Basis me pudieran ayudar con este tema de favor.
Quiero suponer que es algo con el SapRouter, pero la verdad no se nada de Basis.
De antemano muchas gracias,
Saludos,
@Yshua


#2

Hola @Yshua,

¿estás intentando acceder a un webservice desde fuera de tu red local?
Dudo que eso se pueda hacer asi, además, para mí eso contradice todas las normas de seguridad existentes. A los servidores SAP solo se debe poder acceder desde la red interna de la empresa.
No se si es lo que pretendes, si no, deberías aclarar mejor que es lo que quieres hacer entonces.

Un saludo.


#3

Hola Yshua,

Creo que tienes una confucion con el saprouter. El te puede hacer redireccionamiento del sapgui pero no te va a realizar redireccionamiento a un web. Para este proposito debe usar sap webdispatcher.

Cordial Saludo,
William Neira


#4

@wlneira,
Buenos días. Muchas gracias por el apoyo y atención.
tengo esta URL

http://201.151.127.XXX:8010/sap/bc/srt/wsdl/bndg_E725FFF8EE8674F19FC300155D013404/wsdl11/allinone/ws_policy/document?sap-client=200
la cual me envía el mensaje de esta pagina no se puede mostrar.
ya que esa IP es pública, pero si a la URL le coloca la IP del servidor

http://192.168.X.XX:8010/sap/bc/srt/wsdl/bndg_E725FFF8EE8674F19FC300155D013404/wsdl11/allinone/ws_policy/document?sap-client=200
si me direcciona bien, ya me pide un usuario y contraseña, y eso es correcto, por que con la IP pública me envía error?, hay algo que tenga que configurar?, y en donde sería?
De antemano muchas gracias,
Saludos,
@Yshua


#5

Amigos, Gracias a Todos por su apoyo brindado, les comento que ya puedo ver la URL, la solución, fue pedirle a mi proveedor abriera el puerto para que aunque sea IP pública la pueda ver desde mi red, ya que si ejecuta la url desde una red por ejemplo de mi celular, si puedo ver la info de la URL.

Muchas gracias a Todos nuevamente,
Saludos,
@Yshua


#6

Este tema se cerró automáticamente 91 días después del último post. No se permiten nuevas respuestas.