Ayuda SAP

Conexion SQL Reporting services hacia sap BW 7.4

Buenos dias,
Estoy presentando problemas para hacer una conexion desde el sistema SQL server Reporting serrvices hacia SAP BW 7.4 para ejecutar unos Queries y poder hacer un reporte por medio de esos queries en reporting Services. hemos probado las conexiones XMLA y estan ok, la direccion http : http:///sap/bw/xml/soap/xmla?sap-client=100&sap-language=ES;transport Compression=None;Initial catalog=CSDVA_M01… también sale bien. Pero a la hora de hacer la conexion mediante el datasource, sale error A Connection cannot be made. ensure that server is running.

alguien me podria decir que puede estar pasando porfa. que configuracion nos esta faltando? llevamos ya dos semanas con este tema y no hemos podido hacer la conexion.

Muchas Gracias

Esa URL está bien? :neutral_face:
Puedes pasar exactamente el error que te brinda SAP?
Dale doble clic, copia el contenido de la ventana y pegalo aquí.

Gracias

hola si mira la URL es esta

el error nos sale es en reporting services de microsoft.

La URL no puede tener espacios. Fijate bien cómo pinta la URL en la captura que me has pasado.

hola, revise la direccion Http y esta correcta. lo compuebo si yo pego la direccion en el navegador el me da acceso a conectarme con mi usuario:

http:// nombre del servidor/sap/bw/xml/soap/xmla?sap-client=400&sap-language=ES";Initial Catalog=CSDVA_M01;Connect Timeout=0;Transport Compression=None;SAP Client=400;SAP Language=ES

esto es lo que me sale al pegarla en el navegador:

me logueo y me arroja esto

Hola @Bibi.pala si te das cuenta donde dice “Transport Compression” y “SAP Client” tienen espacios por lo que te toma hasta Transport, a eso se refería SidV

intenta poner %20 donde va el espacio

algo así
http://SERVIDOR/sap/bw/xml/soap/xmla?sap-client=400&sap-language=ES";Initial%20Catalog=CSDVA_M01;Connect%20Timeout=0;Transport%20Compression=None;SAP%20Client=400;SAP%20Language=ES

Hola, ensaye con lo que me dijiste de reemplazar los espacios con %20 y me sigue saliendo el error

Hmmm estoy viendo los post de arriba y veo que al comienzo no tenia una comilla (") y despues la pones y bueno yo la puse, intenta usar esta herramienta URL Encode / Decode para encodear los parámetros.

Revisa bien los parámetros que estas usando.

1 me gusta

hola la dirección funciona con o son las comillas en el explorador:

http://_nombre_servidor_/sap/bw/xml/soap/xmla?sap-client=400&sap-language=ES;Initial%20Catalog=CSDVA_M01;Connect%20Timeout=0;Transport%20Compression=None;SAP%20Client=400;SAP%20Language=ES

Ingrese la direccion en el link que me diste y en decodificar me quita los %20 Y en codificar me pone mas de la cuenta y no funciona la url

http%3A%2F%2F_nombre_servidor_%3A8002%2Fsap%2Fbw%2Fxml%2Fsoap%2Fxmla%3Fsap-client%3D400%26sap-language%3DES%22%3BInitial%20Catalog%3DCSDVA_M01%3BConnect%20Timeout%3D0%3BTransport%20Compression%3DNone%3BSAP%20Client%3D400%3BSAP%20Language%3DES

Si entras a:

http://SERVIDOR/sap/bw/xml/soap/xmla?sap-client=400&sap-language=ES

No tienes problemas?

Edit: una pregunta estoy viendo que la URL es http://SERVIDOR/sap/bw/xml/soap/xmla?sap-client=400&sap-language=ES

Pero en los ejemplos de MS veo que toman despues del punto y coma ( ; ) los demas datos como parametros como data string.

Seguro que esos datos se pueden ver por GET como lo estas haciendo tu?

Hola si, si entro solo a esa direccion en la en explorador funciona.
pero si la ingreso en el datasource en Reporting services no funciona. el 400 y el ES es al ingresar los valores de cliente y lenguaje:

Lee este tema: h_tps://archive.sap.com/discussions/thread/3538744
Revisa la conexión RFC por la SM59

En caso de no estar configurado lee esto:
h_tps://msdn.microsoft.com/en-us/library/hh245081.aspx

1 me gusta

holas, revisamos y nada todo esta ok
:frowning:

en la imagen de arriba veo que hay un campo que dice “select or enter a catalog name” el cual esta vacio e intentaste pasar via GET

porque no intentas ponerlo ahi y probar

hola ya se hizo y nada sale el mismo error.

Este tema se cerró automáticamente 91 días después del último post. No se permiten nuevas respuestas.