Ayuda SAP

Error en crystal- vista preliminar de layout

crystalreport
Etiquetas: #<Tag:0x00007f95d0af9cc8>

#1

buen dia,
actualmente estoy tratando de generar una impresion de un layout desde un usuario pero me esta generando el siguiente error al tratar de visualizar la vista preliminar


ademas estuve revisando la gestión de layout y en la fuente de datos hay un cambio con relación a otros informes que también se generan
image
este es el layout que esta generando error
image
este es otro layout que esta funcional
ademas ya realice pruebas directamente desde el servidor y si me permite realizar la impresion pero al tratar de cambiar en la fuente de datos en crystal report me sale el siguiente error

quedo atento si me pueden colaborar con esto ya puse el caso en helpdesk de nuestro partner pero el tema es urgente

muchas gracias


#2

Hola.

Lo mejor es que en este apartado asignes el servidor y base de datos que corresponde, cambia la opción “Dafault” por los datos reales.

Saludos.


#3

hola,
ya hice la prueba pero no me permite realizar ese cambio, realice la prueba en otro equipo y si me permite imprimir y visualizar el layout sin ningun problema, me surge una duda puesto que recientemente elimine archivos temporales de los equipos que estan presentando fallas pero del que esta funcionando no he hecho nada,hay alguna parametrizacion que se almacene en los archivos temporales de windows que pueda estar afectando esto.

gracias


#4

Prueba instalando el cliente nativo de SQL 2012.


#5

ya realice la instalacion del cliente nativo de SQL 2012

pero el error continua presentandose
quedo atento


#6

No presté atención a esto… ¿cómo es que no te deja hacer el cambio?


#7

hola
cuando trato de cambiarlo me solicita un usuario y una contraseña pero no se cual es


que mas puedo tratar de hacer ya actualice el sql client native 2012 en el equipo y sigue sin funcionar

quedo atento

gracias


#8

Con eso tendría que bastar… te está solicitando la contraseña del B1SiteUser, el administrador del sistema debe tenerla, de lo contrario puedes cambiarla pero… es un dato que tu administrador debe tener bien presente.

Saludos.


#9

hola,

el tema es que el administrador soy yo, recientemente empece a trabajar en esta empresa y al revisar en los usuarios dentro del sistema no me muestra el usuario mencionado en la imagen.Como mas puedo solucionar este problema,¿se relaciona con usuario o configuracion del equipo?,hay un equipo desde donde se realizaron pruebas con otro usuario diferente y un equipo tambien diferente y la impresion salio sin problema, pero tengo dudas para realizar pruebas con el usuario que esta funcionando porque de ser configuracion del equipo se podria ver afectado el usuario.

quedo atento


#10

No amigo, el B1SiteUser es un usuario utilizado en la configuración del SAP Server, si no te dejaron documentación de la configuración, podrías apoyarte con tu partner pero si es importante que cuentes con la contraseña de este usuario.

Si decides cambiarlo aquí hay un link muy bueno de ayuda:

h_tps://blogs.sap.com/2013/05/20/how-to-create-a-new-password-b1siteuser-in-882-and-90/

Una vez que tengas las credenciales del B1SiteUser, realizas la configuración.

Saludos.


#11

De igual manera puedes intentar importando nuevamente el Layout.
He tenido el mismo caso, y he visto que sucede cuando:
*En el layout tienes subinformes y este no tiene el mismo nombre del servidor que el informe principal, en tu caso no se si tengas subinformes
*Cuando el layout fue creado con el nombre del servidor y el usuario se esta conectado con la IP del servidor o viceversa

jaja eran 3 casos no recuerdo el ultimo


#12

hola,
pues el proceso que realice fue exportar el informe del equipo y usuario que estaba funcionando y realizar la importacion nuevamente al usuario que estaba presentando inconvenientes y ya quedo funcionando con normalidad.

muchas gracias


#13

Este tema se cerró automáticamente 7 días después del último post. No se permiten nuevas respuestas.