Ayuda SAP

Error "NiHsLGetNodeAddr unknown"

Es la segunda vez que me consigo con este error, viene dado por una incorrecta lectura del SAProuter a la hora del direccionamiento IP, así que les documento la solución.

Primero ubicamos en nuestra maquina el archivo saplogon.ini, o en su defecto SAPUILandscape.xml (En mi maquina solo esta este archivo.

Buscamos la referencia al router y eliminamos del string el valor “/H/” del final. Nos debe quedar de la siguiente manera: /H/XXX.XXX.XXX.XXX

Y pues eso es todo, espero que les pueda ser de utilidad.

1 me gusta

con que version de sap gui te está dando el error?

Version sap gui 7.40.

bueno era lo que pensaba(error que también me ocurrió) es un error que viene ese release del sap gui, la solución es subirle el parche. Yo lo actualicé al parche 10 y ya no tuve problemas

gui740_10-10013011.exe

saludos

1 me gusta

Hola @Shadowdancer,

Es un problema con la versión 7.40 y no sucede en todos los equipos. Gracias por tu colaboración con la solucion.

Cordial Saludo,
William Neira

1 me gusta

No… en realidad no es un problema… un un tema de manejo de Puertos en tu PC… Lo que debes hacer es crear regla de entrada y salida para el firewall de tu PC con el aplicativo SAP Logon.

  1. Control Panel\All Control Panel Items\Windows Firewall (Advanced Settings )

Otra solución Aunque aplica en la versión 7.40 no instalar el SAP Business Client al momento de la instalación.

No olvides eliminar del string router el valor “/H/” del final. Aunque con solo abrir en modo edición SAP lo adapta.

Recuerda: Si tienes Antivirus con el firewall activo debes crear la regla en el antivirus

1 me gusta

supongo que es un error, ya que normalmente no debes hacer este paso con otras versiones de sap gui. Lo que indicas es una forma de solucionarlo similar como se indica en el 1º post.

ver la nota sap 2077230, a partir del patch 3 del SAP gui 7.40 se soluciona

Saludos.

Luego de instalar el SAP Logon siempre se debe instalar el parche, el ultimo parche para el 740 creo que es el 13.

Saludos,

1 me gusta