Ayuda SAP

Error programación ABAP (Dump) LT06

perdon por la tardanza, no he podido resolverlo…el problema es la transaccion LT06 cuando intentan ingresar un tipo de documento, tengo entendido que esta transaccion llama a la LT05 y el error es un error abap que en la ST22 se me presenta asi:

yo no se mucho de Debuggeo la verdad pero he intentado cambiar perfil, darle todos los permisos de esa transaccion, asignar parametros…neles!! nada de nada, hay una chera que si puede correr esa transaccion y todo bien, es quien nos esta ayudando en todo lo que resuelvo pero no le encuentro la razon de porque ella si y yo no.

el error abap lo tira mas o menos asi

1 me gusta

Que tal @Luis_Rodrigue por favor en el dump que muestras localiza la parte del código que esta presentando el problema. para localizarlo buscas en las lineas del dump “>>>>>>”

te muestro un ejemplo.

Saludos.

Si claro, les comparto:


Verifica que los LT06, cuando llama a LT05 no tenga un exit, o código ABAP de por medio, pq en la captura que pasaste es como que veo código en español. Y eso no es para nada normal.

Como asi que no tenga un “exit”? Como verifico la LT06 en si?

Si no sabes debuguear, abre un tema para preguntar sobre eso.
Me referí a que hables con el responsable de los procesos en tu empresa, esa persona debe saber si le han metido “mano” a las transacciones estandar.

El dump se da por un error de programación, hay código mal puesto, que está lanzando el error.

Buenas,

Si eres BASIS este error no te corresponde a ti del todo resolverlo, has hecho lo debido que es identificarlo, como dice @SidV es una ampliación (exit, badi, enhacement ) que se le ha hecho al proceso por algún programador ABAP, este caso ya debería ser tratado por un programador ABAP para que haga lo debido debuggear y identificar que esta causando el error en el código ABAP.

Pero saben lo raro de todo es que a una compañera no le da error pero a mi si, como si fuese por algo en especifico de un usuario, nose si permiso o parametrizacion…eso es lo que me pone a dudar.

Luis, en ese caso, pedile a tu compañera que te pase la captura de cómo ella ejecuta la LT06, y replica exactamente lo que ella carga.

@Luis_Rodrigue Buen día.
Como bien te comenta @SidV ants que nada primer ve si con tu usuario colocando lo mismo que pone tu compañera te envía el error, si es así, entonces, necesitas del funcional y de un Basis y/o ABAP para que valide si dentro del exit (que al parecer es lo más seguro que tenga), no está ligado a que sólo cierto usuarios puedan correr la transacción, igual y hay que agregar tu usuario en alguna tabla de constantes, no lo sé, por ello, es que te sugiero que lo veas con un Funcional de ahí de tu empresa.
Saludos,
@Yshua

si eso hice, me di el “safe” y se lo pase directamente al ABAP que no me ha dado respuesta de momento, muchas gracias!!!

Este foro es el exito jajaja saludos!

Hola Luis_Rodrigue, el dump dice “Field Symbol has not yet been assigned”, al parecer necesitas darle un valor a un Field Symbol.

Este tema se cerró por inactividad.

Copia la URL de este debate, y abre un nuevo tema en #feedback si:

  • El autor del debate no marcó ninguna respuesta como solución, y tú crees tener la solución
  • Crees tener otra solución a la que actualmente está marcada.

Si, en cambio tienes una duda parecida a la que se debatió, o la misma duda, abre un nuevo tema en la categoría que corresponda y pon que el tema se debatió oportunamente (pega el enlace a este debate), así los otros lectores pueden saber de qué hablas.

Ayúdanos a tener una comunidad organizada.