Ayuda SAP

Problemas de impresión SMARTFORMS

Buenos días a tod@s, un gusto saludarles.

Hace unos días hice un smartform el cual genera un documento (una constancia), no obstante al momento de mandar a imprimir esta no imprime las imagenes (logos). Ahora mi pregunta es… me habrá hecho falta configurar algo al momento de cargar las logos a sap?

mi idea era mandarlos a una impresora virtual y de alli que lo imprimieran pero es un doble paso… de igual forma ni en la impresora virtual me aparece imagenes ni texto… si lo imprimo de forma normal solo imprime el texto pero no las imagenes… tienen idea de que puede ser?

por su ayuda muy agradecido.

Alex, te recomiendo leer otros debates d #smartforms … si mi memoria no falla, ya alguien preguntó algo así. :thinking:

Disculpa, no me percaté… de igual forma gracias por tu orientación. Muchas gracias.

como subiste esos logos a sap?
los transportaste?

si, si los cargué en el se78 y los transporte de DEV a QAS, me despliega todo bien, es decir si genera lo que deseo imprimir, el problema es que no salen los logos… vi un caso similar al mio en el foro, ya hice lo que indicaron que debía hacer (abrir mas las ventanas) pero ni aun así… siempre no imprime esos logos.

a eso depende de como lo guardas, el formato y eso.

guardar la imagen en .bmp
y lo subes en
image

como
image

Hola, alexconexion

Si no te salen puede ser que la ventana esta muy pequeña para el grafico mira las caracteristicas del tamaño desde sap, lo otro recuerda que sap solo permite graficos de 256 colores para que se visualice correctamente.

efectivamente esta en formato BMP a color y nada… revise nuevamente las configuraciones

Cuando ejecuto el smartform si salen las imagenes, lo que pasa es que no las imprime… de hecho ya hice las ventanas mas grandes, de igual forma tomare en cuenta revisar lo que me indicas (tamaños y resolucion)

Hola @alexconexion
Estan correctamente configuradas las impresoras con los drivers adecuados en SAP?

Revisé esto y todo se encuentra configurado correctamente… anteriormente se utilizaba un formato que utilizaba imagenes y una de las soluciones es imprimirlo en una impresora virtual (PDF) e imprimirlo desde alli pero eso es agregar otro paso al usuario, y cuando esto pasa se quejan, entonces me pidieron que buscara la forma de hacerlo.

Por si acaso dinos que marca y modelo de impresora estás utilizando y los drivers que has configurado en SAP. Gracias.

por el momento te puedo decir que la marca es Printer y el modelo no lo se porque esta en otro pais la impresora, pero puedo mandar a preguntar y actualizar para documentar este caso

Hola, a mí me pasó que no me imprimía la imagen igualmente y al hacer un debugueo a la función estándar de SAP de tratamiento de imágenes, regresaba un error al procesarla; entonces lo que hice fue grabar la imagen en formato TIF y eso hizo que ya se pudiera procesar; para ello en los parámetros para el procesamiento de la imagen, se debe mencionar que el formato es JP7 y no BMP.

3 Me gusta

Excelente, estaré probando la configuracion como me indicas y que comentaré de los resultados, de ante mano muchas gracias.

si puedes guardar el smartform con el logo por ejemplo en pdf, el problema no es del smartform sino de la impresión. Has la prueba

Gracias por tu respuesta. Cuando guardo el smartform no me guarda las imagenes ni tampoco el texto, y cuando lo imprimo me sale el texto pero no las imagenes… las imagenes unicamente se despliegan en la pantalla.

Excelente, funcionó… muchas gracias amigo. Saludos.

Me da mucho gusto. Cuando me tocó revisar dicho caso, me sorprendió que funcionara de dicha manera, pues la rutina de conversión falla con bmp y en la desesperación, puse TIF, cosas de SAP; que sorprende siempre.

1 me gusta

Asi es mi estimado… suele suceder este tipo de cosas… yo no tengo mucho tiempo desarrollando en abap, pero te puedo decir que en todo tipo de sistemas pasa este tipo de cosas… bueno como decimos aqui en mi pais “pan para mi matate (bolsa)” :smiley: muchas gracias te lo agradezco.