Ayuda SAP

Problemas Puerto 8443

Buenos días chicos…

A ver si me pueden ayudar en algo, no es directamente de SAP o SQL pero me está dando problemas. Les hago un resumen.

Hace 3 semanas el 80% de los celulares de la empresa con IOS se actualizaron a versión 13.
solo los celulares con Android y con IOS12 podían conectarse a la aplicación de SAP Business One Mobile.

El partner ha intentado aplicar notas, hacer pruebas y demás. y no logra hacer que los celulares con IOS13 se conecten. Incluso ya realizó un Ticket a SAP que se supone se conectaran esta semana (aún no tenemos fecha ni horario).

Ahora bien. Veníamos trabajando bien con los celulares que tenían android y IOS12. el día de ayer, el consultor se conectó y estuvo haciendo pruebas nuevas. Tuve que dejarlo como 20 minutos por un tema que surgió de emergencia en otra oficina, y cuando regresé me empezó a informar que el problema era porque tengo el puerto 8443 bloqueado.

Vamos…

  1. Si estuviera bloqueado desde un principio no me hubiera dejado continuar conectarme con la gente que tenía Android y IOS12 ¿no?
  2. Estoy revisando mi Router (porque por el momento no tengo Firewall es algo que quiero implementar en Diciembre) y veo que los puertos los tengo abiertos y routeados. (abajo anexaré imágenes).
  3. la gente de Telmex que es quien me da el servicio de las IP públicas Jura y Perjura que no tienen ningún puerto bloqueado, que si existe algún bloqueo es interno y no de la linea. (también anexaré imágen ya que no le entiendo a esa)
  4. acabo de revisar el servidor, el firewall de Windows está desactivado, y aún así tiene los puertos para SAPBO como abiertos y configurados.
  5. Tengo varias direcciones IP públicas, una que me da problemas es la 18.10, y tengo otra con terminación 18.12 que no tengo problemas (lo menciono porque colocaré la imagen de la configuración de ambas)

La gran pregunta: ¿Que más puedo revisar? (tengo 6 semanas en este nuevo trabajo, aún estoy aprendiendo como está configurada la red y la infraestructura, más aún como le han hecho para hacerla funcionar si no tengo ni un Active Directory, [Cosa que montaré el mes que viene])

Aquí las imágenes (Tapo datos de Ip Publicas por seguridad)
Esta es del problema

Esta no tiene problemas

Redireccionamiento

Ese mismo redireccionamiento lo tengo para la .12 y en esa me funciona a la perfección.

Hola @Ares17000, pudiste revisar esta nota de SAP:
h_tps://launchpad.support.sap.com/#/notes/2847012

Espero te sirva, saludos.

1 me gusta

Utiliza el nmap para saber que puertos tienes abiertos!
por ejemplo


Para utilizar ese comando debes bajar el nmap.

1 me gusta

Buen día,

No es problema del puerto porque antes reconocía el puerto.
El problema es la nueva actualización.
Porque tiene nuevas requisitos de certificado de confianza.
Eso hace que rechace el certificado.
El puerto puede estar abierto y se va mostrar el mismo mensaje.
Porque hay que crear un nuevo certificado.
Si le muestra el mensaje Error de Seguridad es eso.

Primero que se actualicen todos a la versión IOS 13.
Después de eso generar el certificado manual o desde certificate tool pero modificando el openssl.

Ya he creado el certificado para el IOS y me ha funcionado.
Solo es un comentario .
Espero que le sirva.

Hola Jhosser. esa nota y la número 2019275 ya fueron aplicadas y no han dado resultado

abrí el Nmap… no aparece el puerto 8443 ni cuando lo hago a la IP pública, ni cuando lo hago directo a la IP del servidor, (IP INTERNA). he intentado de “abrirlo” por lineas de comando de

netsh advfirewall firewall add rule name="Open Port 8443" dir=in action=allow protocol=TCP localport=88443

Pero solo me arroja un mensaje de “aceptar” y ya.

La cosa es que ya crearon el certificado de seguridad tanto manual como con el Certificate Tool y ninguno de los dos ha funcionado.

Y ahora dicen que es porque el puerto está bloqueado. Pero no entiendo como “esta bloqueado” si no tengo nisisquiera un firewall y ya revisé todo lo que comenté arriba.

La cosa es que ya crearon el certificado de seguridad tanto manual como con el Certificate Tool y ninguno de los dos ha funcionado.

Y ahora dicen que es porque el puerto está bloqueado. Pero no entiendo como “esta bloqueado” si no tengo nisisquiera un firewall y ya revisé todo lo que comenté arriba.

Buen día @Ares17000, también tengo el mismo problema al intentar cargar SAP a los iphone con versión 13 hacia arriba, hable con mi partner y me comento que están trabajado en un nuevo certificado que acepte IOS, que literal lo único que podía hacer era esperar a que liberaran el certificado para la versión 13 o superior, esperemos que sea rápido, Saludos.

1 me gusta

Hola estimado @Ares17000, como bien menciona el buen @kriptonniano, primero debes ver que puertos tienes abiertos o en todo caso puedes hacer un telnet de extremo a extremo haber si realmente esta escuchando el puerto 8443.

Saludos

1 me gusta

Lo hice hoy.
Y me aparece que esta cerrado.
Pero ya no tengo absolutamente más nada que lo pueda estar bloqueando (o no me viene nada a la mente)

Telmex me dice que ellos no son.
Revise mi routers y esta configurado como mostré en el primer post.
En el propio servidor esta apagado el firewall y tiene configurado la apertura de los puertos que mencione.

No me viene a la mente que más revisar

Desactiva tu firewall de tu servidor! y agrega los puerto en configuración avanzada. Y si tiene antivirus tu servidor también desactiva lo a ver que sucede.
Aqui el puerto que mencionas.

Ya lo hice, de hecho mi post justo antes del tuyo indica que es lo que acababa de realizar xD…

Actualizo. Sigo con el problema. No sabemos que se supone que modificó o cambió el consultor del Partner, desde que se puso a hacer cambios en el Integration según “para seguir notas de SAP” el sistema se puso completamente inestable.

Hemos tenido que reiniciar al menos 2 veces al día el server porque los servicios de SAP B1 dejan de responder y no se pueden ni reiniciar ni nada por “servicios”. los paneles de Crystal Dashboard dejaron de funcionar (Resulta que estos usan el puerto 8443 que misteriosamente se encuentra ahora bloqueado pero antes no lo estaba).

hemos tomado por un plan B
El partner no entra más en mi server, y estoy corriendo instalando y actualizando mi servidor de Pruebas que está a la versión 9.3 PL05. (espero hacer eso hoy) y comenzar a probar los AddOns que tenemos actualmente funcionando. cuales siguen, cuales eliminamos.

Y todo comenzó por el certificado para IOS13 que no funcionaba y el Consultor se puso a mover lo que no sabía mover. ¬¬

Restaura el servidor al punto en el que estaba funcionando bien, es decir antes de que le moviera a la configuración tu partner

Acabo de revisar…
Windows server 2012 ya no crea puntos de restauración, sino que uno mismo debe programar las copias de seguridad del server. xD esta madre… jajajajaja
Ya valió.

Igual ando con el Plan B que mencioné ahorita.

2 Me gusta

Hola @Ares17000, lo ideal seria que clones el servidor y veas como se comporta, saludos.

Hola Chicos… retomo el tema.

sigo teniendo problemas. El plan B de un servidor secundario no me está funcionando porque tienen AddOns hechos en casa y al pasar de sap 9.2 a 9.3 dejan de funcionar. y la verdad entre que tengo AÑOS que no programo y que el tiempo no es que me sobre en este trabajo, necesito aplicar un Plan C…

Cual es el plan C?
Pues: Cambiar el puerto por el que se conecta las aplicaciones…

Existe alguna manera de configurar que tanto el integration con el panel del Cockpit como la aplicación de Mobile no se conecten por el puerto 8443?..

Ya no se que más hacer para abrir ese puerto y Windows Server no me deja abrir ningún puerto. NO puedo hacer nada para abrir puertos.

Les explico mi topología actual:

Internet - Router - Servidor
Es decir, por el momento no tengo ningún tipo de Firewall ni nada.

En el router tengo los puertos abiertos:

Los tengo redireccionado

(NOTA: PRUEBA Y PRODUCTIVO ESTAN REDIRECCIONADOS IGUALES)

En windows Server Tengo los puertos abiertos en el Firewall y el Firewall está desactivado (por pruebas solamente)

Regla de Entrada

Regla de Salida

Pero al verificar los puertos contra Productivo me aparecen como bloqueados. Y cuando hago las mismas pruebas contra Pruebas si logro alcanzar el servidor. Ambos están en el mismo segmento de red y la misma conexión (solo que por IP Pública distintas, y no… ya intenté de redireccionar cambiando las IP pública de productivo y pruebas he igual aparece el puerto 8443 bloqueado)

Caso raro: algunos de los otros puertos que se liberaron ahí para el server si aparecen abiertos, ejemplos el 8080 aún puedo ingresar web, y el 30010, pero otros puertos como el 8443 y 30015 que están ahí configurados juntos aparecen como bloqueados.

He intentado de TODO para abrir estos puertos. y no puedo, no me deja el sistema.
Intenté de abrir otros puertos nuevos, como el 9090 o el 9000 para redireccionar el Mobile a esa ubicación y tampoco se abren.

¿Alguna idea?

Buen dia @Ares17000 ,

El puerto 8443 lo esta usando otro programa ?
Pruebe redirigir el puerto 8443 para el 18443 una empresa que conozco hizo eso.
Y le funciona bien.
Para verificar que funciona entra al navegador del celular iphone coloque la siguiente dirección https://ippublica:18443 con esa direccion le tiene que mostrar el login .
Pruebe hacer eso.

Tal vez podría haber servido de solución. Sin embargo ya me quité el dolor de cabeza. En diciembre realicé un formateo del servidor, y ya lo tengo funcionando de nuevo.

Dejaré el tema por si a futuro alguien quiere conocer los posibles cambios que necesiten. y mi solución. “Formatear el servidor”