Ayuda SAP

¿Que me falta para asignar en la VK11?

Buenas tardes.

Soy nuevo en SD. He seguido los pasos para configurar la retención por venta de desechos industriales para un cliente. El indicador de retención ya existe en el módulo FI pero no en el módulo de SD. En FI he configurado la nueva condición:
PAS01X

Pero al configurar en la VK11, me manda este error:

¿Que me faltó por configurar?. Seguí estos pasos:

1.- Crear una condicion de retención ZRET
IMG: Comercial / Funciones básicas / Determinación de precio / Control de determinación de precios / Definir clases de condición

2.- Podemos utilizar la secuencia de acceso estándar J1AW o crear una copia Z1AW para la tabla 399
IMG: Comercial / Funciones básicas / Determinación de precio / Control de determinación de precios / Definir secuencia de acceso

3.- Dentro de nuestro esquema de precios añadiremos la condición ZRET al final, con una cláusula condicional 83 y siempre como condición estadística. He de puntualizar que no acabo de entender la razón, pero toda la información que he consultado coincide en esta forma de actuar.
IMG: Comercial / Funciones básicas / Determinación de precio / Control de determinación de precios / Definir y asignar esquemas de cálculo / Actualizar esquemas de cálculo

4.- Definir el esquema del cliente: Se crean los esquemas para el cliente y van a su vez asociados al esquema de cálculo. Este esquema va a fijarse en el dato maestro del cliente en la segunda vista de ventas.

5.- Fijar esquema de cálculo:
IMG: Comercial / Funciones básicas / Determinación de precio / Control de determinación de precios / Definir y asignar esquemas de cálculo / Fijar determinación esquema de cálculo

6.- XD02: Modificar dato maestro cliente, área de ventas.

7.- Se asocia la clase de condición con el tipo e indicador de retención. Con la famosa VK11 o VK12

Gracias de antemano. Saludos.

Hola @jorgesanchez1

Veo algo sutil en las imágenes, y está mas del lado FI que del lado SD.

En FI hablas del tipo de Retención, y en SD el indicador de retención.
Al parecer falta que configures el indicador de retención en la sección de retención ampliada.
Lo digo por la imagen. No se si tienes la retención ampliada activada.

Saludos.

Hola @maricebs

Gracias por tu respuesta.

Si está configurado el indicador de retención en FI. De Hecho desde la FB70 si se realiza la retención, el problema es que en SD no se realiza aún y cuando el cliente tiene en su dato maestro asignada la retención. He seguido esos pasos pero me atoré en la VK11.

RET02

No se que de los pasos hice mal, o si me falta alguno en el módulo SD.

Gracias y saludos.

@jorgesanchez1

El problema está en que el tipo de retención que asignaste a la clase de condición es el 03.

Y en el cliente estás indicando que está sujeto para otro tipo de retención. En el caso particular de los pantallazos que adjuntas, tienes el indicador 03 para el tipo 02. Lo correcto, para la prueba que estás haciendo sería 03 tanto para el tipo como para la retención.

image

Espero que con esto puedas resolver.

Un saludo

1 me gusta

Hola @avazquezb1975

Gracias por tu respuesta. Intenté asignado en la VK11 el indicador 02, pero me regresa el mismo error.

Indicador de retención 02 no definido para tipo de retención 03

Nº mensaje: 8A143

Diagnóstico

El indicador de retención introducido no se encuentra definido para el tipo de retención asociado con la clase de condición. Corrija el valor introducido.

No se si falte alguna configuración en los pasos que listé.

Gracias y saludos.

Hola @avazquezb1975

Ya entendí a lo que te referías, ciertamente asigné la condición mal, debía asignarla a la 02:

Solucion

Ya lo hice, y pasé mis transportes al ambiente de calidad. Hice una prueba pero no realiza la retención desde el módulo de SD.

No se que esté haciendo mal.

¿Alguien me puede orientar?..

Gracias y saludos.

Hola, la VK11 es dependiente de mandante.
Lo volviste a registrar en QAS?
En tu transporte solo cambiaste las configuraciones y enlaces, pero el indicador que debe determinar debes registrarlo en cada mandante.

Un saludo.

Hola.

Gracias por tu respuesta. Ya revisé todas las configuraciones en el ambiente de calidad, incluyendo la VK11, y si está configurada de acuerdo al procedimiento. Pero aún así, cuando creo un pedido y lo facturo, no se refleja la retención en el documento financiero.

Saludos!!!

Vi que debe estar implementada la nota 178824, revisé en SNOTE y me parece que no está impementada totalmente:

Ejecuté el check que recomienda la nota, el programa ZWTCHECK y me dió este reporte:

SAP Note 02

Me parece que hay algo erróneo, pero no lo puedo interpretar. ¿Debería estar implementada completamente esta nota para que funcione la retención?.

Gracias y saludos.

Este tema se cerró automáticamente 30 días después de la última publicación. No se permiten nuevas respuestas.