Ayuda SAP

Smartforms - espacio salto de pagina

Compañeros, a ver si usted me puedes ayudar con este temita…yo la verdad no lo entiendo y no le veo ni pie ni cabeza.

Ajuste un smartforms, el cual solo le agregue un template y un campo texto, no hice mas nada, no toque logica ni tampoco nada en el programa y ahora el usuario me dice que hay un espacio, en la cabecera cada vez que se pasa de pagina !! es como si cada vez que se pasa a la siguiente pagina, se baja la cabecera.

Quizas sea una tonteria pero yo no la veo…adjunto imagines por si no me entienden.

luego del salto de pagina

@abapers …ideas ???

Buenas,
¿has mirado aquí?

Sigue las indicaciones de @salco y has la prueba con otro usuario para determinar si es global o particular de ese usuario.

Revisa que en la pagina siguiente/next/second page las ventanas estén a la misma altura que en la primera pagina.

Puede ser que las ventanas de esa pagina las hallan movido un poco para abajo. ¯\ _ (ツ)_/¯

@Salco, revise todos los template y todos estan sin ninguna opcion marcada, gracias !!!

@smota, mi pana pasa con el usuario que esta probando y pasa conmigo…en diferentes pc.

@Haden_Yasser_ la broma es esa, que no trabajaron ese smartforms con ventanas ni nada, sino con un loop y dentro del loop estan los template, ni siquiera me dejaba ampliar un poco mas el template !! yo no he trabajado smartforms asi

Adjuntare imagenes para dejar un poco mas claro la cosa…yo de verdad no le veo causa, incluso borre lo que yo habia hecho a ver si fue algo de eso y nada, sigue haciendo lo mismo.


Entonces el problema no lo provocaste tu, es un problema del dispositivo de salida, lanza una linea con cada pagina que sale. Verifica los dispositivo de salida, usa diferentes para asegurarte de que no sea cosa de cambiaran el dispositivo de salida sin darse cuenta.

@smota mi pana con lo que me dijiste lo que me dio fue por revisar en QA y ahi si funciona bien, no tiene errores, algo tuve que hacer…la vaina es que no se que fue lo que hice jejejejeje !!

cuando hablas de los dispotivos de salidas, hablas de las impresoras ?? si es eso, no creo que sea por ahi las cosa porque esta en el codigo por donde va a salir el usuario en ningun momento elige el dispositivo y el codigo del programa si no se ha tocado para nada…no deberia haber variacion y como te comente, esta en el codigo y la orden no se ha pasado…al menos que se pueda configurar un mismo dispositivo para 2 ambientes pero que en cada ambiente pueda comportarse diferente, pudiese ser pero no creo !!! GRACIAS POR LAS IDEAS (Y)

Entonces descarga el smartforms de QA, subelo en DEV y llevalo a PRD, lo dejas funcionando bien y luego vuelve a realizar las modificaciones pero con cautela. Tambien es posible que el de dev alguien lo haya tocado, y cuando subiste tu cambio, subiste los cambios previos y sasgs. Pero si tienes uno bueno el de QA llevalo de DEV y luego a PRD

Pero como el de QA está bueno, el de PRD no ni el de DEV. Fué que pasaste los cambios desde DEV hacia PRD? sin pasar por calidad?

Se burlo del proceso, hizo marrulla, pero por suerte que lo hizo, ahora tiene de donde sacar camino.

Por eso siempre descargo una copia antes de modificar formularios de otro pringao. Y siempre está el control de versiones.

no jajajajaja !! ni siquiera he mandado mi orden a QA ni PR…no ha salido de DEV, me copie de QA como me comento @smota, gracias !!! al paracer, la cosa es por un tema de espacio…yo siempre trabajo los smartforms con ventanas, creo que @Haden_Yasser_ comento algo asi, de la ventas…pero aca no, crearon una logica de proceso (loop) y ahi lanzaron los template y todo eso…yo no trabajo asi y lo que ahora quieren es poner mas espacio entre cada cosa…y yo lo que hice fue eso, agregar el espacio pero en algun lado que no se donde, esta como definido el espacio y parece que si me paso de ese espacio empieza a hacer los saltos…ahora, vean esta imagen

estando asi un smartforms, como le digo que el template X lo puedo agrandar…??? porque asi como esta, si yo lo agrando automaticamente lo vuelve ajustar…simplemente no me deja.

El salto de linea es por eso, porque estoy agragando mas espacio del permitido…donde puedo mover eso ?? como les digo, yo no he trabajado asi los smartforms, siempre pongo todo dentro de ventas y es un jamon hacer esos ajustes

Hola a todos justo estoy viendo una tema parecido, pero en mi caos tengo un problema diferente

has mirado el tamaño de los %MAIN_BODY%?


Y el tamaño de las filas de los templates?

1 me gusta

Listo muchachos, sin recriminar ni nada…me parece que fue que hicieron el smartforms como los picapiedras !!! si se fijan en las imagenes adjuntas, en ninguna habia salto de pagina…que luego de un exhaustivo analisis jejejeje fue que logre entender bien el requerimiento y es que fue un punto en el que ya no podia y lo hable con el funcional que practicamente es otro usuario jejejejeje !!

la cosa es que en el codigo, estaban controlando el largo de la hoja…supuestamente no un maximo de 70 lineas y las demas lineas restantes, osea las que no tenian data, las cargaban vacias…por eso al yo poner un poco mas de espacio entre los template o algo, ese espacio en blanco que no se ve era el que hacia mover la cabecera de la otra hoja !! no se si me explique…lo cierto es que ya ando resolviendo, la cosa es que ahora hay un tema con unos totales, los cuales metieron en la tabla “detalle” y quieren ponerlas en negrita pero como estan dentro de la tabla “detalle” al poner en negrita el total pongo en negrita todo el cuerpo :S !!! ahi tengo que darle unos ajusticos al codigo, para llevarme ese total a una estructura o ponerlos en algunos campos del header para aprovechar codigo y no hacer mas estructuras ni nada !!!

GRACIAS A DIOS !! UNOS MOSTROS TODOS !!!

2 Me gusta

no respondi yo pero gracias a Dios apoyo moral!!! que bueno

Dos tips. En la primera imagen aparecen en español dos veces solo en primera pagina eso por defecto viene mal desde el framework de SMARTFORMS y por lo tanto el primero se logra el salto desde la primera pagina y la segunda si es en la ultima pagina o al final de la pagina. Lo otro es que recomiendo una lectura a la instruccion command en esta pagina: h_tp://saptechnical.com/Tutorials/Smartforms/Command/Index.htm

Esto fue por un mal diseño que tenia el smartforms, por lo que tuve que rehacer muchas cosas !! no dio con una solucion posible…Gracias a todos

2 Me gusta