Ayuda SAP

Error con layout de crystal reports y CDFI

cfdi
crystalreport
Etiquetas: #<Tag:0x00007fe47de60398> #<Tag:0x00007fe47de60168>
#1

Hola Buen Dia Gente del foro!
Quisiera ayuda con este problema que tengo, de hecho ya intente resolverlo con las soluciones que estan en este hilo y nada funciona:

Mi problema es el siguiente
Se genera la factura pero al momento de visualizar en facturacion articulos deudores, me marca un error si implemento un layout con la firma digital del sat, pero si implemento ese mismo layout sin firma digital me lo abre correctamente.
Con sello SAT

Sin sello SAT


Lo raro es que este mismo layout lo tengo funcionando en otro servidor funcionando correctamente y tienen la misma base de datos. De ahi fue donde lo descargue y lo importe.

0 me gusta

#2

cuando te da error con el sello es porque tienes problema es con el XML descargado de esa factura.

  1. Verifica el XML: Busca el XML de esa factura y verifica que esté correctamente timbrado.
  2. Verifica las conexiones: Se que ya lo dijiste que en el otro tema no te funcionó pero no lo dejo por fuera.
  3. Verifica que tengas acceso a la carpeta donde se están guardando los XML: El error se puede presentar porque Crystal está intentando de tener acceso a la carpeta donde están los XML y no tiene permisos.

Recomendaciones para el punto 3:
a) Cuando inicies SAP hazlo con Click Derecho - Administrador Para que tengas permisos completos.
b) Abre una carpeta normal de windows, copia y pega la dirección donde se depositan los XML. Si te pide usuario y contraseña, significa que tu usuario de Windows no tiene acceso a la carpeta.
c) Cuando configures el Crystal Report en el servidor, usa un archivo XML base que se encuentre en la misma carpeta donde debe de leer los XML finales, (por muy extraño que parezca eso ayuda)
d) cuando configures en Crystal la ubicación del XML que ligas al documento (el del paso anterior) no lo hagas con la dirección directa del servidor (ejemplo: No lo hagas direccionando a C:/SAP/Reportes por decir algo), sino que configuralo a leerlo directo a la dirección de RED (Ejemplo: Nombre-Server/SAP/reportes o IP-Server/SAP/reportes) recuerda que la sección de “SAP/Reportes” que te pongo en los ejemplos debe ser la dirección donde se estén descargando los XML en tu servidor, previamente configurado en el módulo de Gestión.

1 me gusta

#3

Gracias lo voy a intentar a ver que resulta!

0 me gusta

#4

Gracias por los consejos pero no se pudo resolver, hasta que ya no iniciaba el sap por que se actualizo windows 10 y tuve que restaurarlo a modo de fabrica porque restaurar un punto anterior no funciono, haciendo esto ya funciona el layout.

0 me gusta

bumped automáticamente #5
0 me gusta